Komplexe Formeln in Excel einfach erklärt

Komplexe Formeln in Excel einfach erklärt

Komplexe Formeln in Excel


Excel bietet ein breites Spektrum an Formeln für den allgemeinen Gebrauch. In die meisten simplen Formeln findet man sich schnell ein. Jedoch besitzt Excel auch viele komplexe und umfangreiche Formeln. Dieser Beitrag befasst sich mit diesen Formeln und ist die Fortsetzung unseres vorherigen Beitrags „Excel Grundlagen – so funktionieren Formeln“.

 

 

Logische Formeln in Excel 

Auch Excel kennt logische Operatoren. Diese sind jedoch nicht einfach nur Symbole, die zwischen zwei Rechnungen gesetzt werden, sondern auch als Formeln verpackt. Im Reiter Formelnin Excel finden Sie die Kategorie Logisch. Hier finden Sie die verschiedenen Operatoren als Formeln wieder. Neben den üblichen UND und ODER Funktionen, ist vor allem die WENN Formel sehr häufig im Gebrauch bei versierten Excel Nutzern. Auf diese wollen wir nun, anhand eines Beispiels, näher eingehen.

 

Lesen Sie auch: Office 2019 im Überblick

 

WENN Formel richtig Anwenden

Stellen Sie sich vor, ein Sportlehrer gibt die Zeiten seiner Schüler beim 100m-Lauf der letzten beiden Wochen in Excel ein. Er möchte nun rausfinden, ob die einzelnen Schüler besser oder schlechter gelaufen sind. Am Anfang sieht die Tabelle wie auf dem unteren Bild aus. Für jeden Schüler stehen nun die zwei Werte der beiden Wochen in der Tabelle.

 

Nun möchte der Sportlehrer in der Spalte D eine 1 stehen haben, wenn der Schüler besser wurde. Wenn er nicht besser wurde oder er sich verschlechtert hat, soll eine zwei eingetragen werden. Hierfür greift er auf die WENN Funktion zurück. In Excel ist diese wie folgt aufgebaut: =WENN(Bedingung; Dann-Wert; Sonst-Wert). In die Klammer kommt zunächst die Bedingung, über die differenziert werden soll. Danach, getrennt durch ein Semikolon, folgt der Wert, wenn die Bedingung zutrifft. Zum Schluss steht der Wert, der bei einer negativen Bedingung angezeigt werden soll.

Zunächst schreibt man für Anna =WENN(B2>C2;und prüft so, ob der neue Wert kleiner ist als der alte. Der Dann-Wert beträgt 1, also sieht die Formel dann wie folgt aus: =WENN(B2>C2;1;. Zum Abschluss wird der Wert eingetragen, der angezeigt werden soll, wenn die Bedingung nicht zutrifft, hier also eine 2. Somit erhält man die Formel =WENN(B2>C2;1;2), welche in Zeile D eingetragen wird. Nachdem man die Formel nun mit Enter bestätigt, bekommt man den korrekten Wert (1) angezeigt.

 

Man kann diese Formel nun wieder auf die unteren Zeilen erweitern und bekommt die entsprechenden Ergebnisse. Außerdem lassen sich in der WENN Formel noch weitere Formeln verschachteln. So kann man zum Beispiel als Bedingung eine UND Formel verwenden. Zudem ist es möglich als Sonstigen-Wert eine weitere WENN Formel definieren, um eine genauere Untersortierung zu ermöglichen. 

 

 
 

ACHTUNG: Wir veranstalten immer wieder spannende Gewinnspiele! Wenn Sie keines verpassen möchten und zudem über nützliche Kurztipps informiert werden möchten, tragen Sie sich in unseren Newsletter ein: 

NEWSLETTER EINTRAGEN